Using Messenger with Escargot on Windows XP, and avoiding the 80048821 error

#41

no one cares about Windows Embedded Standard 2009 anyways.

0 Likes

#42

Yeah, POSReady 2009 is more interesting.
But it will end soon.

0 Likes

#43

not that i care. MSFN will probably provide new updates ported from server 2008 so XP would officialy unofficially half officialy supported until 2020!

0 Likes

#44

and POSready’s unknown predecessors as well.

0 Likes

#45

bump

nobody really cares about POSReady except to get updates for windows xp

0 Likes

#46

thats true :stuck_out_tongue:

0 Likes

#47

This is interesting.

TLS1.1 and TLS1.2 supported in POS Ready.

https://www.microsoft.com/security/blog/2017/10/05/announcing-support-for-tls-1-1-and-tls-1-2-in-xp-posready-2009/

0 Likes

#48

Look what I have just been emailed. If we change our version of XP to think it’s POSREADY we can implement TLS 1.2!!!

Does someone want to give it a try? I’m currently travelling on a Ferry at the moment.

As soon as I get to my hotel I’ll try it in a virtual machine. This change can not be reversed so make sure you understand once it’s done you can’t go back.

0 Likes

#49


Already have it,nothing new to me :stuck_out_tongue:

0 Likes

#50

That’s odd, how did you get that? It wasn’t officially supported or have you done the PosReady trick already :stuck_out_tongue:

So it does work then? :slightly_smiling_face: if only I knew this sooner.

0 Likes

#51

Yeah i have the Posready trick :stuck_out_tongue:
If you want to know more about it,here: https://msfn.org/board/topic/171814-posready-2009-updates-ported-to-windows-xp-sp3-enu/ :stuck_out_tongue:

0 Likes

#52

Yeah it does

0 Likes

#53

Fantastic, thanks. I will check it out shortly.

0 Likes

#54

Hm for some reason I don’t get the option for TLS 1.2. I enabled the registry and installed the KB and rebooted. Checked IE8 settings but it’s not there.

EDIT:

Ran this registry entry and it worked, it’s now TLS 1.2.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\TLS1.2]
"OSVersion"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\TLS1.1]
"OSVersion"=-

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"SecureProtocols"=dword:00000a80
"ShowPunycode"=dword:00000000
"EnablePunycode"=dword:00000001
"DisableIDNPrompt"=dword:00000000
"CertificateRevocation"=dword:00000000
"WarnOnPostRedirect"=dword:00000001
"WarnonBadCertRecving"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Protocols\Mailto]
"UTF8Encoding"=dword:00000000

Got TLS enabled but 8.5 on XP won’t sign in for some reason! . :frowning:

0 Likes

#55


:wink:

0 Likes

#56

I don’t really want to load another application while connecting. Not something I want to do. Things kind just have to work. I tried it though just to test but doesn’t work, still get that error. Followed instructions step by step.

0 Likes

#57

If MS ever flipping added SNI support to xp so we wouldnt need an app to connect with :stuck_out_tongue:

I tried it though just to test but doesn’t work.

I will investigate that then

0 Likes