Using Messenger with Escargot on Windows XP, and avoiding the 80048821 error

That’s odd, how did you get that? It wasn’t officially supported or have you done the PosReady trick already :stuck_out_tongue:

So it does work then? :slightly_smiling_face: if only I knew this sooner.

Yeah i have the Posready trick :stuck_out_tongue:
If you want to know more about it,here: https://msfn.org/board/topic/171814-posready-2009-updates-ported-to-windows-xp-sp3-enu/ :stuck_out_tongue:

Yeah it does

Fantastic, thanks. I will check it out shortly.

Hm for some reason I don’t get the option for TLS 1.2. I enabled the registry and installed the KB and rebooted. Checked IE8 settings but it’s not there.

EDIT:

Ran this registry entry and it worked, it’s now TLS 1.2.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\TLS1.2]
"OSVersion"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\TLS1.1]
"OSVersion"=-

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"SecureProtocols"=dword:00000a80
"ShowPunycode"=dword:00000000
"EnablePunycode"=dword:00000001
"DisableIDNPrompt"=dword:00000000
"CertificateRevocation"=dword:00000000
"WarnOnPostRedirect"=dword:00000001
"WarnonBadCertRecving"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Protocols\Mailto]
"UTF8Encoding"=dword:00000000

Got TLS enabled but 8.5 on XP won’t sign in for some reason! . :frowning:


:wink:

I don’t really want to load another application while connecting. Not something I want to do. Things kind just have to work. I tried it though just to test but doesn’t work, still get that error. Followed instructions step by step.

If MS ever flipping added SNI support to xp so we wouldnt need an app to connect with :stuck_out_tongue:

I tried it though just to test but doesn’t work.

I will investigate that then

It’s not working for me :frowning:


hmm

Yet it doesn’t solve the chipher problem on XP x64/Server 2003(x64)(also it’s wp.xin.at):stuck_out_tongue:

I’m using IE6 on Windows XP RTM… It has it…

What version was TLS 1 introduced?

Also… 0x81000303 appears to be a predecessor to 80048821.
image

i can’t sign in on any of my xp vms

TLS 1.0 has been around since 1999 :stuck_out_tongue:

2 Likes

so… I was able to patch Windows Messenger 4.0 on RTM…
but Windows Messenger 4.7.3000 (on SP2, this time), which came later than 2009 (not to be confused with WLM '09), but before than 3001… doesn’t seem to auth properly.

image
image

I have toogled “MSN 1/2/3/4” support ON and OFF. Nothing.

It seems to be trying to connect, though (1/2/3/4 support is on at this time)
image

Actually, no. it wasn’t.
image

It’s Tweener-based (used on MSN 5.0 and above). You’ll have to patch it like you would with 5.0.

It has been patched. I have used the “SetEscargotServer” 5 times.

It does not connect.
image

On the minor note, I have 4 VMs of XP installed for a (prob going to be shitty) video comparing these four versions.

here’s the MSN versions that’s installed.

RTM: MSN 4.0.0155 (Bundled)
SP1: MSN 4.7.0041 (Bundled)
SP2: MSN 4.7.3000 (Bundled)
SP3: MSN 7.5 (kinda isn’t time appropriate but still, i think some people used 7.5 in 2008ish… so)

I just said like 5.0 so.wouldn’t that mean byte patching?

hex patching? Yep, that was done on the SP2 MSN. (I also had issues of MSN 5.0.0575 not connecting, on XP RTM). So i wonder if there’s some issues with the Tweeners on pre-SP3 XP.

If I remember, even on MD5 versions of Windows Messenger, 4.x will NEVER login, it will hang and right clicking the taskbar icon shows “Cancel Sign In” even after sign-in has “failed”