Disable full screen in WLM 2009

Hello!

I was able to solve some settings for WLM 2009 on Windows 10 20H2, like enabling the icon in the system tray, the WLM taskbar features and change the ad window to the WLM 2009 image, but I have another “bug”: After these settings, WLM 2009 starts as if it were in full screen mode, causing the focus assistant to activate automatically and notifications for some applications are muted.
Are there any boot or configuration parameters in Windows 10 so that msnmsgr.exe does not start as if it were in full screen?

Wow, it’s definitely the compatibility mode that’s causing that to trigger.

I have another idea to workaround this without going too nuclear, I’ll have to do some more testing first though.

2 Likes

Hello @TReKiE,

it’s always a pleasure to see you again!

I also figured this would be a side effect of compatibility, although I am really enjoying WLM 2009. Thank you very much, by the way!

So I will wait patiently for your tests. When you have time, please. Thank you, Jonathan!

It seemed to work out, and I simplified it down to a simple reg file. To try:

  1. Shut down Messenger if it’s running
  2. Turn off compatibility mode in the shortcut and/or msnmsgr.exe, if it’s still turned on
  3. Download and run this .reg file
  4. Say Yes to all prompts to import the key
  5. Start Messenger

I think this also might fix the flicker problem you mentioned before, but I’m not totally sure as it didn’t always happen to me.

2 Likes

You really are the best, Jonathan!

Not only did it fix WLM 2009 full-screen startup in compatibility mode, it also fixed the taskbar flicker! :heart_eyes:

I am very happy for your support. Thank you very much!