Creating your own WLM 2009 server the easy way


#81

image
Help me. I don’t have VMWare installed.


#82

I am getting this error: whats the problem?

Serving on 0.0.0.0:80
Serving on 0.0.0.0:1863
Serving on 0.0.0.0:1864
Serving on 0.0.0.0:52478
Traceback (most recent call last):
  File "C:\Users\vamos\AppData\Local\Programs\Python\Python37-32\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "C:\Users\vamos\AppData\Local\Programs\Python\Python37-32\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "dev\__main__.py", line 6, in <module>
    main()
  File "dev\__main__.py", line 3, in main
    run_all.main(devmode = True)
  File "C:\Users\vamos\Desktop\msn-server-feature-wlm2009\run_all.py", line 39, in main
    backend.run_forever()
  File "C:\Users\vamos\Desktop\msn-server-feature-wlm2009\core\backend.py", line 89, in run_forever
    run_loop(self.loop, self._runners)
  File "C:\Users\vamos\Desktop\msn-server-feature-wlm2009\util\misc.py", line 120, in run_loop
    servers = loop.run_until_complete(asyncio.gather(*foos))
  File "C:\Users\vamos\AppData\Local\Programs\Python\Python37-32\lib\asyncio\base_events.py", line 584, in run_until_complete
    return future.result()
  File "C:\Users\vamos\AppData\Local\Programs\Python\Python37-32\lib\asyncio\base_events.py", line 1378, in create_server
    % (sa, err.strerror.lower())) from None
OSError: [Errno 10048] error while attempting to bind on address ('0.0.0.0', 443): only one usage of each socket address (protocol/network address/port) is normally permitted

#83

The 443 error is because of VMware.


#84

got it now 81000605 error


#85

Why don’t you give us the source code so we can have WLM 2012 support?


#86

pretty sure messaging doesn’t work, bud


#87

The day after i was able to connect to my server, I decided to nudge another contact, it worked, then the other contact nudged, only 1 window shaked.


#88

#89

Hello
I always get this error message!
maybe someone can help me


#90

simple as that


#91

Yes I have I have Visual C++ 2017 with Python and Buildtools 2015 what do I know but it always comes to the same error !! I don’t know what to do.
or am I using the wrong version of Visual Studio there are three? :smiley:


#92

it does mention a missing header named “math”. you could also try installing the Python development tools from the Visual Studio installer if you haven’t already done that.


#93

Install Visual C++ from VS 2017 Installer


#94

Umm it doesnt work for me


#95

I got all that fixed but now i got this problem, someone pls help me


#96

I have the same error, pls anyone pls help


#97
NLN FLN

Last time I tested WLM 2009 it didn’t send an offline notification to myself. How are you being sent that? o_0

(Related, exactly what branch did you clone from?)


#98

I got it from the branch that I was linked to by the person who posted this thread, I downloaded the latest commit. Did I do something wrong? I’m confused, send me the link to the branch I’m meant to download from. I downloaded from WLM 2009 branch


#99

Strange that you’d get that bug, then. I even cleared Python cache to see if it’d pop up, and it was still fine for me. :confused:


#100

give me the one you downloaded like zip it up and upload it here or somewhere and let me see if it would work, i think it could be something to do with branch being uploaded.