Creating your own WLM 2009 server the easy way

It technically still works, but aside from the change of branches for the latest code, this release is done. It’s just a matter of patching clients for it and rolling out the updates. I advise people to wait until everything’s released. If they still want to get their own WLM 2009 server up, more power to them. However, people who don’t understand the internals of the group chat system can’t easily remove members or change their roles, nor can they leave unless they can fiddle with the database and manually set stuff by themselves (or they can make a web component that can interface with the group chats). WLM 2009’s HOSTS settings are also inconvenient and if you have to use Microsoft’s services or Escargot for some reason, then they’d have to go back and forth to toggle the entries.


Now i have a problem with “C:\Users\Alessio\AppData\Local\Programs\Python\Python37-32/lib/” what i can do for resolve it ?

1 Like

Reinstall Python, it may be fucked up

Wth i reinstall it i still have the error :confused: im using master branch

Here is the error :

Traceback (most recent call last):
File “script/”, line 40, in
import funcli
File “C:\Users\Alessio\AppData\Local\Programs\Python\Python37\lib\site-packages\”, line 7, in
from typing import List, Optional, Dict, Callable, Any, Tuple, Set, get_type_hints, GenericMeta, Iterable, Sequence, Union
ImportError: cannot import name ‘GenericMeta’ from ‘typing’ (C:\Users\Alessio\AppData\Local\Programs\Python\Python37\lib\

use python 3.6 ffs

1 Like


Omg thanks it workkk !

I got stuck in the HLL error thing, did all the repairs, installed the build tools and nothing worked.
Someone can help me?

This is the error:

  ERROR: Command errored out with exit status 1:
     command: 'C:\Program Files\Python37\python.exe' -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\User\\AppData\\Local\\Temp\\pip-install-x9d0xbe4\\HLL\\'"'"'; __file__='"'"'C:\\Users\\User\\AppData\\Local\\Temp\\pip-install-x9d0xbe4\\HLL\\'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\User\AppData\Local\Temp\pip-record-3ejopopp\install-record.txt' --single-version-externally-managed --compile
         cwd: C:\Users\User\AppData\Local\Temp\pip-install-x9d0xbe4\HLL\
    Complete output (11 lines):
    running install
    running build
    running build_ext
    building 'HLL' extension
    creating build
    creating build\
    creating build\\Release
    creating build\\Release\src
    creating build\\Release\lib
    cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG /MD "-IC:\Program Files\Python37\include" "-IC:\Program Files\Python37\include" /Tcsrc/hll.c /Fobuild\\Release\src/hll.obj
    error: command 'cl.exe' failed: No such file or directory
ERROR: Command errored out with exit status 1: 'C:\Program Files\Python37\python.exe' -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\User\\AppData\\Local\\Temp\\pip-install-x9d0xbe4\\HLL\\'"'"'; __file__='"'"'C:\\Users\\User\\AppData\\Local\\Temp\\pip-install-x9d0xbe4\\HLL\\'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\User\AppData\Local\Temp\pip-record-3ejopopp\install-record.txt' --single-version-externally-managed --compile Check the logs for full command output.


you wont get the server to work after this anyway since it uses GenericMeta, which is only used in 3.6 and below

Now I installed 3.6, and I have this error.

Command "C:\Users\User\AppData\Local\Programs\Python\Python36\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\User\\AppData\\Local\\Temp\\pip-build-gt37n6r8\\HLL\\';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\User\AppData\Local\Temp\pip-15rjrmy9-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\User\AppData\Local\Temp\pip-build-gt37n6r8\HLL\

Use Python 3.6, 3.7 is not compatible with Escargot at any way

that is literally what i said you troglodyte

So i live in a cave :stuck_out_tongue:

yes you prehistoric fuck

Is there any fossil of me when I’m making your post go derailed? (fuck)

Python 3.7 is indeed compatible with the local server, you just need an edited
(Which is in C:\Users\username\AppData\Local\Programs\Python\Python37-32\Lib\site-packages).
Here’s the edited version. Replace it with the older one to get 3.7 to work. (2.1 KB)
And if you’re having issues installing HLL, check my post above.


I installed Python 3.5.4 and solved the HLL problem, but I have this error now.

 File "script/", line 2, in <module>
    from core import db, stats
  File "C:\Users\User\Documents\msn-server-master\core\", line 10, in <module>
    from util import hash
  File "C:\Users\User\Documents\msn-server-master\util\", line 8
    HASHERS: Dict[str, Type['Hasher']] = {}
SyntaxError: invalid syntax

You need 3.6. Judging from the error, it looks like 3.5 and below don’t support the typing annotations (it’s for enforcing data types) in the code.

It still works? Is there any errors?