Messenger geek in internet explorer 8


#61

ie 8 is outdated , you should use ie 11


#62

i know.but im running xp right now and that’s the last version that supports xp.


#63

eh , that’s a poblem


#64

Well it’s not like you’re forced to use IE


#65

i know but my ie8 downgraded into a stupid ie6 but my ie6 can go on snailscape chat still.so in my review it’s a meh 5/10


#66

How did it downgrade to ie6?


#67

I DON’T KNOW! how did it I DON’T KNOW!


#68

i’M ALREADY ABOUT TO UPGRADE AGAIN SO WHY!


#69

Maybe because xp comes with ie6?