Mercury messenger is really broken?

i use mercury messenger on my phone but, when i login with my correct username and password and protocol 15 then it saysinvalid username or password😞

If you have pfsense it will probably block the connections.

yeah i have.

thats your problem :stuck_out_tongue:

yes i have a tp link signal amplifier but there is also a normal huawei router.

Parece ser un problema general… yo uso red gsm y wifi en ninguna de las dos redes funciona, incluso luego instalar/desinstalar y borrar los datos almacenados en caché y almacenamiento primario


Does not work with me too :confused:

I have the same problem, mercury app not working with escargot msn now :frowning_face:

Probably a issue with the client or the server :stuck_out_tongue:

Up until recently I haven’t come across any major issue with Mercury Messenger. Now that I hear all this, I decided to finally install it on my Android Pie device and try it out. First thing I notice is that the background tiles instead of stretching, which seems like an obvious indicator of the application’s age. When I log in with MSNP15 as the protocol it just straight up cancels the operation as soon as it tries to verify the password, in which the cause is unknown to me at the moment (I don’t know enough about Android to properly get network captures from my device and IDK about emulators right now). Either way I believe this is an obvious sign that Mercury has outgrown usability on modern Android and that the only real solution would be to develop a new Messenger client from scratch. I realized I oopsed with the server and didn’t know Mercury used RST2.srf. The issue’s been fixed.

1 Like

Oh, I think I know what the problem is now.

Recently I commented out the RST2 handler in code as I assumed the only uses were from people trying to get WLM 2009 working (don’t ask) and I guess I unknowingly disabled Mercury Messenger support by doing that. I’ll go reenable it lol.


Yeah everything’s back to normal now. Sorry for the inconvenience lol. :stuck_out_tongue:


i have tried Mercury on Android 9 (before the problem) and it worked fine, other than the tiled background, that you already mentioned.

Yes I just came out with news that I goofed up on the server-side and that I fixed the issue.

Funciona perfectamente, gracias

Not working

Please help

No not works.

Make sure the protocol settings on your account are set to MSNP15. That’s the only thing that makes Mercury Messenger reliably work atm.