Error code 8004882a with Windows 10 build 10074 and above


#1

The latest versions of Reviver since 2.4.4 don’t require this workaround.

On two (of three) machines that I recently upgraded to Windows 10 build 10061, I got error code 8004882a when I tried signing into Messenger

The error is somewhere in the authentication process, but the error doesn’t make much sense (The partner DNS used in the login request cannot be found).

In the process of investigating the problem, I managed to fix the issue but I’m not entirely sure what the problem is yet as I haven’t been able to reproduce the problem again.

Regardless, if you’re experiencing the problem, you can try this fix too and report your results.

Firstly, you’ll need Windows Photo Gallery installed. If you don’t already have it installed, download the Windows Essentials Installer, select the Choose option, choose the Photo Gallery and Movie Maker option and click Install.

Then just start Windows Photo Gallery and make sure you are signed in in the top corner with your Microsoft account.

After that, try signing into Messenger again.

Hopefully this can be studied further, so far I’ve come up empty trying to get the problem to resurface on new installs.


The msn 2012 is installed, but appears the error message 8004882a
#2

Unfortunately, this doesn’t seem to work. I opened up windows photo gallery, then tried signing in and i still get the error.

EDIT: Okay. I figured it out. It seems that the only MSN account that I was able to sign in to WLM is the one I used to log into windows 10 itself.

In other words, it seems that if you use an account that is DIFFERENT from the account you use to log into windows, it will not work, and will still give you “Service temporarily available.”


#3

That wouldn’t have been my problem specifically as I’ve only ever used the one account on these machines.

However, I can confirm I get the same message when trying to use another account, making the problem reproducible on demand. Nice catch.

I’m not sure yet if this is a bug in this build specifically or an incompatibility going forward. Messenger relies on Windows to do authentication in 8, 8.1 and 10 and they may have changed something in their “Windows Live Login Service”.


#4

I have the same problem after upgrading from Windows 8.1 to Windows 10 build 10074. I do use a different account from the one I sign onto Windows vs my WLM account since I log onto a domain.
The odd thing is, immediately after the upgrade, I was able to log into WLM with no problems. Even rebooted several times throughout the day with no problems. The issue and error didn’t show up until the next day when I booted up my computer.


#5

This has been fixed when you re-revive with Reviver 2.4.4.


#6

I can’t seem to get 2.4.4 to work. I get an Unhandled Exception, “The given key was not present in the dictionary.”


#7

At what point does this happen?
Do you have all Windows Updates installed up to this point?
Just to confirm, what version/build of Windows do you have? 64-bit or 32-bit?
Any other detail you think would be helpful would be great.


#8

It happens immediately upon the window opening.
Only update I have listed as being available is TH1 Enterprise 10240. I’m running Build 10162 x64 Enterprise. Haven’t updated to 10240 since I read Enterprise won’t activate past 10162.


#9

Got it, I dropped the ball there on the detection it seems. At the moment this will only work for 10240.

When I get a chance, I’ll add support for 10162 and update the thread when that’s done.


#10

If it’s too much trouble, don’t worry about it. This thread seems to imply there’s a way for Enterprise users to activate 10240. I may give that a try tomorrow.


#11

Shane here. I too have the same issue of needing to log into Photo Gallery everytime I boot the computer before I can log into Messenger. The only time I don’t need to do this is when I just restart the computer instead of shutting it down. This problem persists even with Reviver 2.4.4, and I’m on the latest build of Windows 10 as well. So what’s the issue around this?


#12

Please try 2.4.5 (released today) and report back.

Build 10162 is also supported now as well.


#13

Just tested the new build. It works now. Thanks John. :smile:


#14

New Build works on Windows 10. Thanks.


#15

Hi there. I still get the same problem, I can’t log in with a different account from the one I sign onto Windows 10. I’ve just downloaded the new build of Messenger Reviver and now I get this error code: 8004884b . Any ideas? :frowning:


#16

It worked for me. Thanks very much.

I am having problems getting Outlook 2010 to work with Gmail. Imap works but cannot send. Now I have Live Mail working all is fine. If anyone is having similar problems with Outlook and Gmail make sure that you have 2 step verification set up in your gmail account and MAKE A NOTE OF THE 16 digit number. You will need it for Live mail.


#17

I am having similar problems to the above but getting error code 800488e7 when logging in (which i can’t find any information on anywhere)
: tried the windows essential installer asmentioned above on the off-chance but then when trying to open photo gallery get 0x8007007e error message: problem loading WLXPhotoLibraryMain.dll (have tried re-running reviver 2-4-5-1 as well). stumped.


#18

Ok so I have managed to get it back up and working, not sure exactly which process worked (or if it was a combination of more than one) but here’s what I did in case anyone else out there gets the same error message:

after trying to re-install windows essentials unsuccessfully and still having issues with missing library, I installed media feature pack N & KN from here and re-started to try and correct the issue with the image gallery - which fixed error code 0x8007007e and allowed the image gallery to work, but could not sign in here.

re-set my sign in (Settings>Accounts>Your Account) for my computer so I sign in with windows live to sync accounts (though never used to do this), and then re-set my sign in method for windows live to a pin system rather than password.

signed in successfully in the image gallery window and then was able to sign in to messenger…


#19

Strange. On the afternoon of the 25th, I kept intermittently losing connection and then finally it quit. My wife was having the same problem on her end, except she’s running Windows 7 and I’m on Windows 10 10240. Morning of the 26th, hers can log in now. Mine wouldn’t work all day, error 8004882a. Today the 27th, still not working. Just me?


#20

I have revived messenger with 2.4.5.1 and it works fine.