Creating your own WLM 2009 server the easy way


you might want the build tools. get them here:

as for, create it and include these lines:

DEBUG = True


y̶e̶a̶h̶ ̶s̶t̶u̶c̶k̶ ̶i̶n̶t̶o̶ ̶t̶h̶a̶t̶ ̶s̶a̶m̶e̶ ̶d̶e̶a̶d̶ ̶e̶n̶d̶.̶ ̶i̶ ̶d̶o̶n̶’̶t̶ ̶r̶e̶a̶l̶l̶y̶ ̶w̶a̶n̶t̶ ̶t̶o̶ ̶u̶s̶e̶ ̶8̶.̶5̶ ̶w̶i̶t̶h̶ ̶a̶ ̶2̶0̶0̶9̶ ̶t̶h̶e̶m̶e̶.̶

Actually never mind i didn’t saw @reesehan_schavinchi1’s intrusctions

Although i’m stuck on another dead-end, There’s a error that says that i don’t have the HLL module. What is that?
I have visual studio.

I tried to install HLL with pip and it didn’t worked. the error also said “HyperLogLog” so i installed that and i REtried using the python command with no result.


again, if you have visual studio already, you will need build tools.

i probably shouldn’t have overlooked this in my tutorial but i was under the assumption that no one needed build tools because (for me) HLL wouldn’t compile without Visual Studio so i assumed it was all that anyone needed. sorry about that.


It still says the error, i have visual studio and the 2015 build tools

image .



maybe try looking in the Visual Studio installer for building/Python related stuff?





try it i guess


It requires Visual C++ 14, i have Visual Studio Community.

Update: After 20 minutes of installing Visual C++ i was FINALLY able to install HLL.


And i’m stuck in here.

OSError: [Errno 10048] error while attempting to bind on address ('', 443): only one usage of each socket address (protocol/network address/port) is normally permitted

Connecting will only result 80072efd

It seems that it wants to use the ip “”, which makes no sense for me at all.

So i have to port forward everything?


try installing Windows Live Messenger 2009 fresh from the MSI and install the Windows Live Communications Platform. if already done then check HOSTS.

# Copyright (c) 1993-2009 Microsoft Corp.
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
# For example:
#          # source server
#              # x client host

# localhost name resolution is handled within DNS itself.
#       localhost
#	::1             localhost


run python

also is like localhost and


It actually mentions 2 times and 2 times.


I now get error code 80048820. Although most people say that it’s because TLS wasn’t enabled (since it’s the same error code as using 8.x on Windows XP without the posready updates)


alright, try python dev again.

#35 says that there’s 2 ips that has,

dev says that ALL ips have,


ok, then connect.



ok, looking at it, it mentions that it wants 443 but it can’t use it because a program is already using it.

if you have VMware Workstation/Player, terminate vmware-hostd.exe. if you have any web server software, disable it.


vmware-hostd.exe was open. So i closed it and.


It now has error code 80048820.


did you install the included certificate correctly/at all?