Windows Vista 5219 and Firefox

Hello and welcome to yet another useless thread of mine. This thread will cover an issue that plagues builds from 5112 up to 5231, and how to fix it (atleast firefox until version 20).

On this thread, i’ll be using Firefox 20 as its the newest version 5219 can run (i expect the same result from 5231 or even 5112).

Lets assume you have a normal 5219 installation. Ignore firefox for now, we’ll need to work with IE7 beta.
Why? you can’t really install any browser at this point. You’ll NEED to cooperate with Internet Explorer and all of the certificate errors since i have no idea how to de-bomb this build and you’ll be running it on 2005 or 2006 date.

Anyways, Open up internet explorer. Bing will work without a hitch and won’t throw certificate errors but it’ll look wacky. You can search for 7zip yourself on bing since the site will open up properly, only with a certificate error that can be ignored.

After downloading and installing 7zip, we’ll need the Firefox 20 installer. Grab it from the firefox repository, you can just look up on bing “Firefox Repository”; it’ll be this:image
Look for image . Don’t mistake it with 2.0.

After Downloading the installer, Extract the installer using 7zip:
Open the “Firefox Setup 20.0” folder and take the “core folder”. This contains the browser files. Put it somewhere else.

Anyways, with that out of the way, lets get resource hacker going. Sadly, that’s not really an easy task. Downloading from the site will throw the “Side-by-side configuration error” that plagues not only firefox but aloooooot of things. We need version 3.6. You’ll need a ton of patience to copy this entire url into internet explorer:
If done correctly, you should see a download pop up:

Save the file and extract it to a folder. Lets get going with resource hacker. Open it up and look for the file “firefox.exe” inside the core folder mentioned previously:
Bring down 24, and then 1, and open up “1033”:

Look for a line similar to this:
It’ll have “asInvoker” instead of “requireAdministrator”. Thats the point, replace it with requireAdministrator, press the compile button and save the file.
Right click the newly made firefox.exe and go onto the properties (not resource hacker). Set compatibility to windows xp:

Apply. Congratulations, firefox should run.

Keep in mind the certificate errors will persist and messengergeek wont open for some reason. This’ll be barely enough to do anything, as youtube won’t really work.


this isnt useless

this should just be a made into a installer or something.

I made a installer for it, If it works on 5219 or doesn’t, tell me.

Revision 2.1 fixes some other shit.
Revision 2 fixes some laughable mistakes.

if you edited the nullsoft installer, it won’t work

It isn’t the nullsoft installer, it’s a new installer built from the ground up with InstallForge.

No side by side error or anything (tested on a OS that isn’t the target OS but i’ll try it tomrrow or whatever)

I tried, uhh, it’s broken,

however i bet it’s a bug within build 5384, i haven’t really tried 5219 and 5259 as build 5308 fucked up recently.

that’s 5308, it doesn’t have the UAC bug

5384 you meant.


5308 is fucking unstable, the OOBE was slow to death, and it crashed twice.

you can help me in one thing and that is giving me the beta gadgets