Why AIM doesn't work on Windows 10?

I’ve just downloaded AIM 5.1 by phoenix for Uglyows10 coff coff Windows 10 but when i run it the entire pc goes in a freeze-status where i cannot do anything… even the task manager freezes if i open it. How i can solve this problem? :\

1 Like

so, exist a pogram to fix that on AIM phoenix website

have you tried compatibility mode?

Download Aim-tamer, it fixed most of my crashing issues. It’s available on Phoenix’s website like what @PPCB said. Make sure to run it before you launch Aim itself, otherwise it wouldn’t have any effect on controlling AIM.

Mine too. So Do NOT Run AIM when your PC Starting.
Or next time use AIM Tamer.

Mine works fine :stuck_out_tongue:

Problem solved for AIM… Windows 10 is a sh.t on my Windows 7’s pc it works fine

Good

Agreed, 10 uses somehow 1.6gb idle RAM…

I’ll suggest to microsoft’s feedback application something like: “If you want to update your shittows 10 forever please do something for Windows 7 too” :\

Windowswindows 10 sucks at old apps compatability

Well you can pay Microsoft to get extended updates… but that’s for Enterprise users only :slightly_frowning_face:

A way i easily simplified the process of running AIM on my windows 10 pc is that i added AIM Tamer into my startup folder in windows 10 and it’d launch at startup and i set it to also open minimized so it wouldn’t slow down loading my desktop.