-Videocall- error 0x0 {WLM 2012}


#1

When im Trying to call somebody i have this error 0x0
Whats wrong? please help!!


#2

@Tasos_Anas Is using valtron server with MSN 7? Video calls are probably not yet fully implemented.

Also, Winks are not received by contacts.The server is still experimental.


#3

Mateus is right, I haven’t even looked at implementing video/sound/winks. But I thought they all worked via P2P, like the file transfers/display pictures, which seem to work right now.


#4

No i mean wlm 2012 not 7.0


#5

Depending on what you’re trying to do will be specific to the versions as more are on the table again. (I see you changed this to be specific to 2012 as I was writing this, but I’m not deleting all this and it is mostly relevent :smile:)

In the versions of Messenger prior to 4.0, Messenger’s voice capabilities are on a port 6901 and require specific ALG for Messenger voice if you’re using a NAT (ie. router).

Windows Messenger and MSN Messenger versions prior to 7 use the built-in Real-Time Communications API in Windows XP for voice/video that require Universal Plug and Play (UPnP) to be functional on any NAT you might be passing through.

Beginning in MSN Messenger 7, they add the “webcam” feature (brought to you by Logitech, a big deal at the time), which uses a relay/proxy server and generally made that feature work almost all the time.

In Live Messenger they forked their own improved of the RTC API, added their own relay server for video calls, and slowly improved the NAT situation, even supporting symmetric NATs. The 2012 version was the best for this, also improving the video codecs to support higher resolutions.

The biggest challenge with using video calls on Messenger now is that with the relay servers no longer operational, you really need a working network setup for videocalls to work. That means you’re back to the Windows/MSN Messenger days needing either a public IP address (not likely) or a NAT/router with working UPnP support, preferably on both sides (although Messenger 2012 supports reverse connections, loose UDP, etc.).

As a starting point, you could try accessing your modem or router’s configuration page, turning on UPnP if it’s turned off and rebooting.


Voiceclips in 7.5
#6

i have the same error.Ok,so videocalls doesn’t work?