Problems with Plus 4 and 5 (Not workng/Not showing up)

Last post that I’m gonna make here before moving out.

So, I’ve been trying to install Live Plus 5 on WLM '09.

For some reason it doesn’t show up and instead gives me this error, despite reinstalling Plus like 15+ times. (yes i also have made sure to erase the hell out of it) PlusService_LrXlxvZjzG
Even tried to go from WLM 8.1 and 8.5 with Plus 4 (even WLM 8.1 and 8.5 dont show Plus! though 7.5 does detect Plus 3), still wont show up.
I have my anti-virus disabled and made several exclusions, even tried running it in compatibility mode.
Also tried installing in a different directory and trying to find out something in regedit if possible.
Any help?

(Yes, the PlusService.exe is also running and has signs of activity. I seriously don’t know what’s happening.)

UPDATE: Even after so many days, I still can’t make it work. And where the hell is everyone?

just click cancel

I don’t know if English isn’t your first language but, literally in the text, I said.

The icon that’s for Plus wont show up in messenger. And no options too.