.NET 3.5 Install problem

I have started making source engine (The engine used by Half Life 2, Portal 1/2 and Garry’s Mod) maps and I need to use VTFedit to edit the screen of an Apple II prop I had imported. However upon launching VTFedit it tells me that .NET 3.5 needs to be installed (Screenshotted). I click on “Download and install this feature” and it stays on “Downloading required files” for a few seconds and throws a 0x800F0950 error. Any ideas on how to sort this?

Screenshots:
image
image
image

These guides might help you:

Thanks for the help, but I am running the latest version of windows, and I have no spare drives to dedicate to the windows 10 installation media disc