Error code 80072745


#1

Since 2 days my MSN does not work and I get a message error code 80072745. If I do a check concerning the internet connections it stucks on the key-ports. I surged the internet and tried a lot of things but nothing worked


#2

im having the same error, since the last 2 days. Might it have something to do with the new version of Skype (7.0)? I updated it exactly 2 days ago, it might have messed up something since they share the messenger protocol part…


#3

I won’t totally dismiss Skype being a factor completely, but software-wise they are completely different and probably has nothing to do with it. Also, I use Skype 7 and have no problem. Also, this problem started showing up immediately after the Messenger changes a few weeks ago, not the Skype 7 release.

If you haven’t already done so and you’re using Messenger 2009, please re-revive using the latest version of Reviver (2.3.5).

Either way, getting [connection logs][1] from both of you would be a great start to troubleshooting. Also you might want to review [this thread][2] from a few days ago. My gut feeling is that there’s a specific software that you might have installed that is causing this issue.

Also, knowing what version of Messenger and Windows you’re using, would be a great help too.
[1]: Making a connection log
[2]: Error 8100030d/80072745 sign in errors


#4

thanks for the answer, my log file is here https://www.dropbox.com/s/e3ogdit9nm92f9e/MsnMsgr.txt?dl=0 also on windows 8.1 (probably also 7-8) the file can be found in the hidden folder C:\Users\yourusername\AppData\Local\Microsoft\Messenge, maybe you can update your guide :wink:

platform: Windows Live Messenger 16.4.3528.0331 on Windows 8.1


#5

Any news already ? I have deleted Skype from my computer but still no changes MSN doe not work the error code 80072745 is still valid and detailed.


#6

I have the same problem :(. please anyone make a fix


#7

well… it started to work again yesterday… and today. No explanations, i havent’ uninstalled or removed anything.


#8

%userprofile%\Local Settings\Application Data\Microsoft\Messenger does is in fact take you to C:\Users\yourusername\AppData\Local\Microsoft\Messenger, as there are NTFS junctions to make it happen. The advantage to writing it in the first way is that it’s works universally on Windows XP all the way to Windows 10 Preview.


#9

well, it doesnt work for me, it tries to take me to “Local Settings\Application Data\Microsoft\Messenger” which doesnt exist on windows 8.1. That’s why i had to go there manually :smile:

Simone


#10

Hm, they should exist but they are junctions, not real folders. Keep in mind that you’re denied access to navigate to them (to avoid getting in recursive loops), so you need to go exactly to the right folder from the Run box or Explorer address bar.

Hopefully you don’t know all this, but if you open a Command Prompt (Prompt dei comandi in Italian), and assuming you didn’t open one with administrator rights, you should already be in your user folder, do dir /a:d and check out the directories underneath.

These all are for compatibility with existing Windows versions, so as mentioned before, if you try and get them directly, you’ll get “Accesso negato”. Are your junctions in Italian or are they missing completely? I’ve switched my language but even after forcing the default language to the system/new user accounts, everything still uses the English names (which is how I thought it should work as normally the localized names should be an Explorer thing).

If you’re interested at all, while you’re there, you can create your own junction to see how it works. So doing

mklink /J “simonetest” “pictures”

Will create a junction called simonetest that is effectively the Pictures folder. If you open them up in Explorer, side-by-side, you’ll see that they’ll be identical.


#11

thanks for the detailed explanation, i already use some junctions myself to sync some folders on dropbox. I thought, as you do, that the junctions keep the english name and leave the localized names for Explorer, but it doesnt seem to be the case, with dir /a:d i can see the Junction “Dati applicazioni” which is exactly the translation for “application data” and it points to AppData. Changing the system locale to english doesnt help as it doesnt translate the directory names.

thanks :smile:

Simone


#12

Sorry for the slow response, I’ve been meaning to write up what I discovered about this whole thing.

In XP, it seems to work as we expected, at least in the language editions I have anyway. That is, these Application Data and Local Settings folders (the real ones, not junctions of course) are in English, regardless what version was installed.

But once you get into the newer versions where these are junctions, not only can they end up in the language that was installed, but they might not exist at all. For example, the Estonian version of Windows 7 (from Microsoft’s MSDN) doesn’t make any junctions. I’m guessing maybe (at least initially) there wasn’t an Estonian version of XP, so they didn’t bother? Or maybe someone forgot!

Hard to say, but it’s pretty clear I can’t use that scheme to easily support multiple versions and languages. Thanks for bringing this to my attention, much appreciated :slight_smile:


#13

ooook, good to know, and happy to be of some help! :slight_smile:

thanks for all your work, really, much appreciated!