Err_ssl_protocol_error

#1

Tried to visit the escargot website but, this popped up.


Translation: This site cant establish a secure connection.

#2

Windows version please?

#3

Mac OS Mojave, I use iMac as my main. Webbrowser is Chrome.
This never happened to me before, probs the new protocols ded

#4

Fix ERR_SSL_PROTOCOL_ERROR by setting the correct Date &Time Sounds too obvious, doesn’t it? Well, most of the time, the simplest solution to a problem is the correct one. In this case, incorrect date & time settings might be causing trouble for you. So, make sure that your system isn’t lagging behind or running ahead. Fix ERR_SSL_PROTOCOL_ERROR by clearing Chrome’s Browsing Data From one obvious solution to another. If you already have the correct date & time, it’s time to clear Chrome’s cache and cookies. To do so, press Ctrl + Shift + Delete and erase your browsing data. Even if this hasn’t fixed the “This site can’t provide a secure connection” error, we recommend clearing your browsing data on a regular basis. Fix ERR_SSL_PROTOCOL_ERROR by clearing your SSL State If neither of the above works, clearing your SSL State is the next thing you should try. Follow the steps below to do so: First, go to Customize and control Google Chrome, the three dots you see just below the X (close) button. Now click on Settings. Scroll down the page and open the Advanced Settings. Go to Open proxy settings by scrolling down or searching in the search bar. A window named ‘Internet Properties’ will open up. Go to the Content window and click on the Clear SSL State Button. Fix ERR_SSL_PROTOCOL_ERROR by disabling QUIC Protocol QUIC (Quick UDP Internet Connections) provides a TLS/SSL equivalent connection to Google’s servers. By default, the QUIC protocol is enabled in Chrome. To disable it, copy chrome://flags/#enable-quic and paste it into the address bar, hit enter. On top of your screen, the Experimental QUIC Protocol would have been set as Default. Disable it and relaunch Chrome. Fix ERR_SSL_PROTOCOL_ERROR by checking your Antivirus Settings Warning: This step isn’t entirely safe as it allows the older, insecure SSL/TLS protocols that some of the websites still use. You might not know this, but your Antivirus software keeps an eye on the web pages you visit and protects you against any threats they may pose or contain. It does this by checking the SSL/TLS protocol a website uses. Upon finding the protocol to be unsafe and outdated, it prevents you from visiting the site. There isn’t any one particular way to change the settings for all Antivirus software as the UI and settings differ from one software to another. You’d have to find and see if it’s scanning the SSL protocols. If it does, disable it and see what happens. If the problem persists, revert to the original settings. Fix ERR_SSL_PROTOCOL_ERROR by Enabling all SSL/TLS Versions – The Last Resort Warning: This step isn’t entirely safe as it allows the older, insecure SSL/TLS protocols that some of the websites still use. When you visit an SSL-enabled website, it uses SSL/TLS protocols to communicate with the server. Sometimes, the SSL/TLS version of a website might not be compatible with your Chrome as Chrome doesn’t permit deprecated SSL/TLS protocols to run by default. Therefore, you’d need to change those SSL/TLS protocol settings. Here’s how you can do it: Click on the three dots you see in the top-right corner of Chrome and click on Settings. Now scroll down and go to Advanced Settings. Find the Proxy settings and open it. Click on Advanced Scroll down till the Security section comes up. Now make sure that you have checked all SSL and TLS versions. Click Apply. Relaunch your Chrome. We hope that this guide has helped you fix ERR_SSL_PROTOCOL_ERROR or “This site can’t provide a secure connection” messages on Chrome. And if it doesn’t, share your concerns in the comments section and we’ll try to help you out with it.

Read more at: https://www.thesslstore.com/blog/fix-err-ssl-protocol-error/

#5

Tried deleting cache and cookies, didnt work.
Time and date are set correct, proxy is disabled.
Its probably the website update that messed it up.

#6

For me it doesnt give that error on my phone amd my 7,xp pc

#7

I dunno but it never happened to me.

#10

The error message ERR_SSL_PROTOCOL_ERROR error indicates that the browser is not able to initiate the secured communication at the moment. It’s almost impossible to pin it down to a single cause, it could be almost anything. There is no definite guide for managing this error. However, there are few changes or settings which help you to get rid you of this error.

  • Configure Correct Date and Time
    
  • Clear Browsing Data
    
  • Clear Your SSL State
    
  • Disable QUIC Protocol of Chrome
    
  • Disable your Internet Browser Extensions
    
  • Adjust Your Internet Security and Privacy Level
    
  • Remove your system's hosts file
    
  • Check Your Antivirus Settings
    
  • Check Your Firewall