Dont Know where to post but read below

As you may know. a few days ago @mina354 Encountered a sound distortion on his vmware WinXP vm, Today the same happened to me with my WinXP (and also with my Win2k vm), its unknown why it happened but i found this:

image

The problem seem like its because of this. which also its a problem for those that they use Windows NT 5.x VMs (Aka WinXP or Win2k?), but even if you disable it still will not work. so i suggest all those that they use these Guest OS to download this: GitHub - Raymai97/VMAudioBack: Workaround for VMware guest OS Audio Distortion (Windows) that run natively in Win2k and XP without needing DotNet framework. it will fix the sound distortion problem.

also if i made some english mistake, tell me and i will fix it.

Just simply running windows media center in the background can temporarily fix the issue. All VMAudioBack does is just play a silent MP3 on a loop. In the source code, there is an “a.mp3” present. (The location is /source/dist) According to the github page, it may not work if the host runs Windows 7 or below.

VMAudioBack is a simpler version of what I use, which is VMAudioFixTray. To get VMAudioFixTry to work correctly, you will need .NET 3.5. MS still provides .NET 3.5 in it’s bootstrapper and full form. (Full form is recommended, as it’s not reliant on the internet, nor online MS services.)

side channel mitagations are a feature for security purposes but it can be disabled if you have vmware pro

i found a solution. you can fix it by disable VBS ( Virtualization-based security) in windows 11.

EDIT: the solution worked. now my WinXP vm doesnt have distorted sounds anymore.

Please share how to do this.

1 Like

It won’t matter which method to try, right? What’s important is that I make VBS not running. So far, I tried Local Group Policy Editor to disable VBS and then restarted, but it still says “Running” in System Information.

It always happens to me

Except for Virtualbox but idk what it happens for the issue