Can't install my own msn-server

Hi I am trying to make my private MSN server to work
I am following this: https://gitlab.com/valtron/msn-server/blob/master/CONTRIBUTING.md

after installing ubuntu server 17.04, installing python3.6 and putting required line to .baschr:
#Python PATH
export PYTHONPATH=/usr/lib/python3.6

I cloned the repo and starting installing requirements with python -m pip install -r requirements.txt

everything went well until I wanted to create a database
I copied settings.py to settings_local.py and tried to execute python3.6 cmd/dbcreate.py but I got:
mitja@msn:~/msn-server$ python3.6 cmd/dbcreate.py
Traceback (most recent call last):
File “cmd/dbcreate.py”, line 1, in
from db import Base, engine
ModuleNotFoundError: No module named ‘db’

so I assumed that it can’t find db.py so I copied everything out of cmd into root dir I cloned repo to and tried again this time with python3.6 dbcreate.py and it worked (how can I have everything in cmd/ and still make it work?)

PS: can I change default domain of m1.escargot.log1p.xyz to msn.dxing.si?
PPS: how can I activate developer mode in this man patcher: https://gitlab.com/valtron/msn-server/issues/23 because if I just open it it doesn’t give me custom option

Thanks for Anwsering and Best Regards

Configure PYTHONPATH to include the directory where your module resides and python will be able to find your module.

PS: can I change default domain of m1.escargot.log1p.xyz to msn.dxing.si?

m1.escargot.log1p.xyz = 21 digits.

u need edit the IP in the Client… and use 21 digits…

1 Like

well I created root cert imported it into my test maschine install MSN 7.5 on it copied patched dll patched it with Escargot-Autopatcher 1.2 in Developer mode with theese details:
MSNP Server: msn.dxing.si
Nexus Server: https://msn.dxing.si/nexus-mock
PassportURLs: Passporturls
(6.0+ only) MsgrConfig: https://msn.dxing.si/etc/MsgrConfig?padding=qqqq

and tried MSN with foo@hotmail.com dummy account:
sess.add(User(
uuid = ‘00000000-0000-0000-0002-000000000001’,
email = ‘foo@hotmail.com’, — Username = foo@hotmail.com
verified = True,
name = “Foo”,
message = “Ahoy!”,
password = hasher.encode(‘foopass’), — Password = foopass
settings = {},

in the server I get this:

mitja@msn:~/msn-server$ sudo python3.6 dev.py
Serving on (‘0.0.0.0’, 80)
Serving on (‘0.0.0.0’, 1863)
Serving on (‘0.0.0.0’, 1864)
Serving on (‘0.0.0.0’, 443)
26593 nb con
26593 nb >>> VER 7 MSNP12 MSNP11 MSNP10 CVR0
26593 nb <<< VER 7 MSNP12
26593 nb >>> CVR 8 0x0424 winnt 6.1 i386 MSNMSGR 7.5.0324 msmsgs foo%40hotmail.com
26593 nb <<< CVR 8 7.5.0324 7.5.0324 7.5.0324 http://url.com http://url.com
26593 nb >>> USR 9 TWN I foo%40hotmail.com
26593 nb <<< USR 9 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1
26593 nb dis

but in the client I got Error: 80048821 (Your username and password is not correct, blah, blah, blah)

I don’t realy understand this line: 26593 nb <<< CVR 8 7.5.0324 7.5.0324 7.5.0324 http://url.com http://url.com (shouldn’t it say http://msn.dxing.si)?

PS: where do I need to follow this 21 digits limit? (in the settings_local.py file?)
why there is a 21 Digit limit?

Thanks for Anwsering and Best Regards

The limit of 21 digits, is that when modifying the client side … in hexadecimal … the original value is 21 digits … and you must replace the texts with others of equal size … in this case … . m1.escargot.log1p.xyz … has the same value to be able to complete the 21 original digits occupied by the “ip” of microsoft.


I have the same problem to log in into a dev server… (download and use the NEW server files… has been update 2 day ago…) Have the script to create account… and new guide to install…

But i can’t log in…

so I am not alone in this
well wil try fresh with m1.escargot.log1p.xyz first and see if I can get it working (probably not)
PS: I think the guide needs to tell to install some header files: sudo apt-get install libffi-dev libssl-dev because if you don’t do that you can’t create SSL Cert and private key when running python3.6 dev

PPS: why when patching msn client we need to change PassportUrls to passporturls?
PPPS: is there any Escargot-Troubleshooter-1.0 for custom server chacks (if you want to chech your custom msn server) (like Escargot-Troubleshooter-1.2)
Offtopic (21 digit limit): this one should do it: prijava.msnp.dxing.si

add 127.0.0.1 m1.escargot.log1p.xyz in the host file… to try in localhost…

i mounting it on windows (most easy) when i can understand how it’s server file work… i migrate it to Linux

PS: IDK… i prefeer PassportUrls ( to use the UpperCamelCase to standarise the code)

Offtopic: Yes xD

I tried again with default settings_local.py and have set my DNS server to resolve m1.escargot.log1p.xyz to my server ip (192.168.88.44), pathed MSN 7.5 and I am able to get a connection but I get Error: 80048821 again but and much the same server response:
Serving on (‘0.0.0.0’, 80)
Serving on (‘0.0.0.0’, 1863)
Serving on (‘0.0.0.0’, 1864)
Serving on (‘0.0.0.0’, 443)
6966 nb con
6966 nb >>> VER MSNP12
6966 nb <<< VER MSNP12 0 MSNP21 MSNP20 MSNP19 MSNP18 MSNP17 MSNP16 MSNP15 MSNP14 MSNP13 MSNP12 MSNP11 MSNP10 MSNP9 MSNP8 MSNP7 MSNP6 MSNP5 MSNP4 MSNP3 MSNP2
6966 nb dis
7557 nb con
7557 nb >>> VER MSNP12
7557 nb <<< VER MSNP12 0 MSNP21 MSNP20 MSNP19 MSNP18 MSNP17 MSNP16 MSNP15 MSNP14 MSNP13 MSNP12 MSNP11 MSNP10 MSNP9 MSNP8 MSNP7 MSNP6 MSNP5 MSNP4 MSNP3 MSNP2
7557 nb dis
7646 nb con
7646 nb >>> VER MSNP12
7646 nb <<< VER MSNP12 0 MSNP21 MSNP20 MSNP19 MSNP18 MSNP17 MSNP16 MSNP15 MSNP14 MSNP13 MSNP12 MSNP11 MSNP10 MSNP9 MSNP8 MSNP7 MSNP6 MSNP5 MSNP4 MSNP3 MSNP2
7646 nb dis
7721 nb con
7721 nb >>> VER 1 MSNP12 MSNP11 MSNP10 CVR0
7721 nb <<< VER 1 MSNP12
7721 nb >>> CVR 2 0x0424 winnt 6.1 i386 MSNMSGR 7.5.0324 msmsgs foo%40hotmail.com
7721 nb <<< CVR 2 7.5.0324 7.5.0324 7.5.0324 http://url.com http://url.com
7721 nb >>> USR 3 TWN I foo%40hotmail.com
7721 nb <<< USR 3 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1

Request: POST https://m1.escargot.log1p.xyz/NotRST.srf

7721 nb dis

Request: GET https://m1.escargot.log1p.xyz/NotRST.srf

7927 nb con
7927 nb >>> VER 4 MSNP12 MSNP11 MSNP10 CVR0
7927 nb <<< VER 4 MSNP12
7927 nb >>> CVR 5 0x0424 winnt 6.1 i386 MSNMSGR 7.5.0324 msmsgs aa
7927 nb <<< CVR 5 7.5.0324 7.5.0324 7.5.0324 http://url.com http://url.com
7927 nb >>> USR 6 TWN I aa
7927 nb <<< USR 6 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1

Request: POST https://m1.escargot.log1p.xyz/NotRST.srf

7927 nb dis
could anyone tell me what what this response mean (it is probably telling me what is wrong?)
PS: the account for testing was the same as before (even created one with user.py email=test@test.si password=test)
Thanks for Anwsering and Best Regards

I’m going one step ahead of you xDDD

Maybe you’re have not installed the generated certificate.

thats great were you able to sign in?

I’ve tried with MSN 7.0 patched (server is the same as before but I regenerated SSL Cert and again installed into Trusted Root Certification Authorities store (at least I think so:

)
but on MSN 7 I get a difrent error:

mitja@msn:~/msn-server$ sudo python3.6 dev.py
Serving on (‘0.0.0.0’, 80)
Serving on (‘0.0.0.0’, 1863)
Serving on (‘0.0.0.0’, 1864)
Serving on (‘0.0.0.0’, 443)
21838 nb con
21838 nb >>> VER MSNP12
21838 nb <<< VER MSNP12 0 MSNP21 MSNP20 MSNP19 MSNP18 MSNP17 MSNP16 MSNP15 MSNP14 MSNP13 MSNP12 MSNP11 MSNP10 MSNP9 MSNP8 MSNP7 MSNP6 MSNP5 MSNP4 MSNP3 MSNP2
21838 nb dis
21907 nb con
21907 nb >>> VER 1 MSNP11 MSNP10 CVR0
21907 nb <<< VER 1 MSNP11
21907 nb >>> CVR 2 0x0424 winnt 6.1 i386 MSNMSGR 7.0.0820 msmsgs foo%40hotmail.com
21907 nb <<< CVR 2 7.0.0820 7.0.0820 7.0.0820 http://url.com http://url.com
21907 nb >>> USR 3 TWN I foo%40hotmail.com
21907 nb <<< USR 3 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1

Request: GET https://m1.escargot.log1p.xyz/nexus-mock

21907 nb dis
21942 nb con
21942 nb >>> VER 4 MSNP11 MSNP10 CVR0
21942 nb <<< VER 4 MSNP11
21942 nb >>> CVR 5 0x0424 winnt 6.1 i386 MSNMSGR 7.0.0820 msmsgs a
21942 nb <<< CVR 5 7.0.0820 7.0.0820 7.0.0820 http://url.com http://url.com
21942 nb >>> USR 6 TWN I a
21942 nb <<< USR 6 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1

Request: GET https://m1.escargot.log1p.xyz/nexus-mock

21942 nb dis
22027 nb con
22027 nb >>> VER 1 MSNP10 CVR0
22027 nb <<< VER 1 MSNP10
22027 nb dis
22063 nb con
22063 nb >>> VER 7 MSNP11 MSNP10 CVR0
22063 nb <<< VER 7 MSNP11
22063 nb >>> CVR 8 0x0424 winnt 6.1 i386 MSNMSGR 7.0.0820 msmsgs aa
22063 nb <<< CVR 8 7.0.0820 7.0.0820 7.0.0820 http://url.com http://url.com
22063 nb >>> USR 9 TWN I aa
22063 nb <<< USR 9 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1

Request: GET https://m1.escargot.log1p.xyz/nexus-mock

22063 nb dis
22081 nb con
22081 nb >>> VER 10 MSNP11 MSNP10 CVR0
22081 nb <<< VER 10 MSNP11
22081 nb >>> CVR 11 0x0424 winnt 6.1 i386 MSNMSGR 7.0.0820 msmsgs aa
22081 nb <<< CVR 11 7.0.0820 7.0.0820 7.0.0820 http://url.com http://url.com
22081 nb >>> USR 12 TWN I aa
22081 nb <<< USR 12 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1

Request: GET https://m1.escargot.log1p.xyz/nexus-mock

22081 nb dis

(it aphears that Passport stuff is faling (nexus-mock) and MSN Client gives me 80070194 error)
I am not sure what I am doing wrong (any cmd command to install SSL cert into Trusted Root Certification Authorities store)

Thanks for Anwsering and Best Regards

WTF lang? xD

no in can’t loggin… in spanish when i try install… have 2 options very similar… and idk which to select…

i go to install a windows in english version to test it…

u need install the msn-escargot them

the Language in the picture is Slovenian (or Slovenščina as we call it)

you can also install SSL Cert with this command: certutil -addstore “Root” “c:\cacert.cer” (where “c:\cacert.cer” where you have your certificate stored)

what did you mean by that? (I wonder how if you want to use Escargot servers you don’t need to import any SSL Certificate?)

Ohh… thanks for advance, i try to install the certificate…

EDIT: well i installed with your command but… not loggin :frowning:

and…

msn-escargot = https://gitlab.com/valtron/msn-escargot

(The web)

so it isn’t a certificate fault :slight_smile:
will try to use prepatched version first and if that fails I will use prepatched version and msn-escargot (the site)

im using the prepatched version and i put “127.0.0.1 m1.escargot…” in the host file…

The client tries to log in, and in the console appears, which is also not a problem of the prepatch…

Only… “wrong” password…

Serving on ('0.0.0.0', 80)
Serving on ('0.0.0.0', 1863)
Serving on ('0.0.0.0', 1864)
Serving on ('0.0.0.0', 443)
51798 nb con
51798 nb >>> VER 4 MSNP12 MSNP11 MSNP10 CVR0
51798 nb <<< VER 4 MSNP12
51798 nb >>> CVR 5 0x0c0a winnt 6.1 i386 MSNMSGR 7.5.0324 msmsgs testemail%40
hotmail.com
51798 nb <<< CVR 5 7.5.0324 7.5.0324 7.5.0324 http://url.com http://url.com
51798 nb >>> USR 6 TWN I testemail%40hotmail.com
51798 nb <<< USR 6 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1
51798 nb dis

51798 nb <<< USR 6 TWN S ct=1,rver=1,wp=FS_40SEC_0_COMPACT,lc=1,id=1 == wrong password? (Thanks for tellimg me)
BTW: can someone tell me what all this debug stuff mean (or direct me to where I can read about it?)
Will try escargot-site than

it’s error wrong user name or password… (exist in the database)

the error appear in the client…

Uhmm read the GitLab… https://gitlab.com/valtron/msn-server have some information

‘Entidades de certificación raíz de confianza’

The only issue I had was that I got an error when running dummydada.py:

sqlite3.IntegrityError: NOT NULL constraint failed: t_user.password_md5

This happens with master and dev branches, but not with feature/wlm. In this branch you can see ‘Add required MD5 password to dummydata’ in the last commit.
Creating a user manually works just fine and I was able to log in.

Did you delete the certificate you installed before?

Did you delete the certificate you installed before?

hmm how to delete old certificates?

From the Start menu or a command line run certmgr.msc. In the left panel select ‘Trusted Root Certification Authorities’ > ‘Certificates’, on the right select the certificate, right click and ‘Delete’ or Action menu, ‘Delete’.

Perfect i delete all certificates of escargot… i go to have lunch and try.