"Error establishing a database connection"


#1

http://escargotspaces.com/powerwindows/
my website won’t load and it pops up this error :sob:
escargot spaces = brick???
/s
aight but seriously the fuck is going on


#2

I did secure the DB file permissions yesterday since it was apparently downloadable before then.

I’ll temporarily restore the original permissions and see if that fixes the problem.


#3


#4

Well restoring the DB’s original permissions and accessing the blog doesn’t change anything.

Try making a new blog now.


#5

i dont know how to i havent used spaces in months :sob:


#6

Guess that means your blog was created long before I changed the DB permissions.

Maybe WordPress borked something up. :confused:


#7

no i just made a new acc idk why lmao


#8

Oh. :stuck_out_tongue:


#9

so yea how idk


#10

So I decided to create a dummy space on the admin account and I also get the same error.

I’ll try restoring the DB permissions once again and create yet another Space.


#11

So I created yet another dummy Space, this time with the (very risky) permissions set, and I’m getting the same error.

Maybe there’s something else wrong. :confused:


#12

:<

filler e e e e e e e e e


#13

Checked out the error log.

There seems to be a lot of “Table doesn’t exist” errors.

And from checking phpMyAdmin, the tables WordPress complains about not finding don’t exist. O_O

Perhaps I’ll run a repair on the database and see what happens. :stuck_out_tongue:


#14

wat


#15

So I’m currently getting a deployment version of Escargot Spaces working, with the theme and all, to see if I can reproduce or figure out the problem the actual Spaces currently has.


#16

After setting up the deployment site, I created two test blogs on it, pre and post-BuddyPress installation, and both blogs were accessible. I then had the feeling that the database on the main site was screwed up, and from searching up the error, I can pretty much conclude so.

Guess it’s time to reinstall WordPress.


#17

Before I reinstall WordPress though, I’ll need to back up the existing users and functioning blogs that are already in the database. Unfortunately, phpMyAdmin wasn’t cooperating with me when I tried exporting the tables, so I’ve successfully set up MySQL Workbench to remotely connect to the Escargot Spaces database, and I’ll do the backup tomorrow. :slight_smile:


#18

k


#19

Finally got to fix the bug, but it seems that the UTF-8 characters got screwed up along with it.


#20

UTF-8?
Like Unicode?


Spell “Pig” backwards and then say “pretty colors” to win a free ipod nano 5th generation